what is more fringe than a telnet bbs?

Synchronet over decnet

Synchronet over decnet

A bbs over decnet!

I found a simple c server and client program that was ported to decnet.  And it was easy enough to follow I thought I’d try something fun.  So I took Synchronet 3.00c and started to identify the winsock tcpip portions and then slowly alter them to either stubs or being more decnet friendly.

Surprisingly this wasn’t so hard.

The hard part is that decnet doesn’t have a telnet like protocol,  and I don’t have enough patience to try to reverse how ctermd works, so with a lot of searching I found a semi simple telnet client and mostly got it running on decnet.   Right now I have issues resolving address,  so it is hardcoded.

I have to admit it was pretty cool to see the first connection,  even though it aborted when it couldn’t figure out my ip address.   I made some more changes, and it worked!!

The next step was to fire up gns3 and build a simple 2 area decnet network and see if a NT box from area one could connect to a bbs in area two.  And with a few false starts I finally got a working multi area network (decnet isn’t like tcpip!!) This document on cisco’s site was invaluable.

Simple GNS DECnet network

Simple GNS DECnet network

As you can see this is pretty simple.  I wanted two serial connections so I could run DECnet on one serial connection, and TCP/IP on the other.  This way I could shut down the TCP/IP connection to ensure my conversation was 100% over DECnet.

R1:

decnet routing iv-prime 1.1
decnet node-type area
!
interface FastEthernet0/0
ip address 192.168.0.1 255.255.255.0
duplex auto
speed auto
decnet cost 20
!
interface Serial1/0
no ip address
decnet cost 20
serial restart-delay 0
!
interface Serial1/1
ip address 10.5.0.1 255.255.255.252
serial restart-delay 0
!
router rip
network 10.0.0.0
network 192.168.0.0

 And R2:

decnet routing iv-prime 2.1
decnet node-type area
!
interface FastEthernet0/0
ip address 192.168.2.1 255.255.255.0
duplex auto
speed auto
decnet cost 10
!
interface FastEthernet0/1
ip address dhcp
duplex auto
speed auto
!
interface Serial1/0
no ip address
decnet cost 10
serial restart-delay 0
!
interface Serial1/1
ip address 10.5.0.2 255.255.255.252
serial restart-delay 0
!
router rip
redistribute static
network 10.0.0.0
network 192.168.2.0

 As you can see the configuration is pretty simple.  I went with RIP because it’s a small network, and I only need a few routes.  EIRP, OSPF and friends are just pure overkill.  And recall VMNet8 is the NAT interface provided by VMWare Player.

Checking output from the routers, shows that DECnet is routing, and that I can ping both of my test NT boxes:

R1#show decnet route
Area Cost Hops Next Hop to Node Expires Prio
*1 0 0 (Local) -> 1.1
*2 20 1 Serial1/0 -> 2.1 44 64 A+
Node Cost Hops Next Hop to Node Expires Prio
*(Area) 0 0 (Local) -> 1.1
*1.1 0 0 (Local) -> 1.1
*1.3 20 1 FastEthernet0/0 -> 1.3 65
R1#ping decnet 1.3

Type escape sequence to abort.
Sending 5, 100-byte DECnet echos to atg 0 area.node 1.3, timeout is 5 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/7/12 ms
R1#ping decnet 2.5

Type escape sequence to abort.
Sending 5, 100-byte DECnet echos to atg 0 area.node 2.5, timeout is 5 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/34/60 ms
R1#

 Everything is looking good! I fired up my DECnet telnet and success!!

Success!

Success!

Anyone crazy enough to want it can find the BBS on sourceforge, along with the telnet client.

Another OS/2 Synchronet BBS

It’s always cool to see them pop up in the wild.  So here is the quick writeup on gabucino.be going over some of the trials of setting up bbs.gabucino.be ..

And apparently he’s had far better luck getting the modems to operate well more like modems.  So no cheating as I did by using passive mode FTP to transfer QWK packets in & out of the system.  Its all very cool, and of course powered by OS/2 on Qemu so that makes me happy!

There isn’t a flash/java based page, so I’d recommend using syncterm.

Domain Poker

No really this isn’t some cheezy ad for ‘internet poker’.  Wait, well maybe it is.  Anyways I was on my Synchronet with a friend when we tried ‘Domain Poker’, and the version that shipped with Synchronet for DOS-OS/2 is the trial version.  And it’s old.  So while googling for an updated version I came across dpok2k.zip

Happy Y2K and beyond!
In support of the renewed interest in Synchronet BBS Software and it’s expectedtelnet capabilities some of you have been asking for registered versions of theold Domain Entertainment doors.  Instead, I’ve gone ahead and recompiled thesome of the doors (the games) so that they don’t require any registration.
Be aware that Domain Entertainment no longer makes, sells, or supports BBSdoors so use these at your own risk.  Domain Entertainment assumes no liabilityfor errors or omissions in these files or damages resulting from the use ofthem.
You may freely distribute this software so long as it is distributed in it’soriginal form with all accompanying files.

Wow that’s pretty cool!

So I’ve loaded it up on my BBS, and I’ve also updated the ‘bubble‘ BBS.

Although I don’t know poker for crap, any time I’ve won it’s with ‘neutral computers’ that don’t cheat. lol

fTelnet .. another web based telnet application

While browsing around for some hints on how to configure LORD (Legend of the Red Dragon) on Synchronet, I stumbled upon fTelnet.

The one interesting feature that fTelnet has is Ymodem-G support in the browser.  Sadly for the life of me I can’t figure out how to get it to work…

So for now if you want to try it, it’s available here on my test system…

I’ll have to detail the whole OS/2 on Qemu & Synchronet experience later.

Some updates..

I had a request for the qemu 0.90 binaries to run NeXTSTEP… I don’t own Vaxenrule.com anymore so for now I’ll put them here:

http://dl.dropbox.com/u/1694005/qemu090%20for%20nextstep.zip

Sorry for the bitrot stuff… 😐 At least I’m still here.

Also while working on Tradewars C today, I came across this great package called OpenDoors. Even better is that it’s under the LGPL. The only “downside” is that OpenDoors requires Visual C++ 6.0 or higher to build, because of the toolbar.. Also I’m not sure if going from VC 1.0 to 9.0 didn’t flake some stuff out as well… I’m not 100% sure about it, but the trading part of the game feels.. weird.

The examples are pretty straight forward, and it took a few hours on & off for me to convert the standalone tradewars into a door program. I like the feel of it so much I may try to see about converting SIMH to run with it.. Maybe even dumbfrotz.

OpenDoors trade wars

OpenDoors trade wars

Above is a picture of what the console looks like.

Synchronet / Synchterm BBS fun!

 

Well the last while I have ‘rediscovered’ the fun of BBS’ing. There is a resurgence of popularity of the Synchronet BBS software. The cool thing about it is the ease to setup the QWK messages (it just uses ftp!) and within 30 minutes of downloading and installing I had myself a node VERT’s quicknet!

You too can download your very own BBS software here.

There is even a GREAT terminal emulator suitably named Syncterm that completes the experence. It supports rsh, telnet, ssh, x/y/z modem and cool ANSI graphics!

Another exciting aspect of the whole thing is that you can easily link up USENET servers with this BBS software… And of course it provides some involved web server wirtten in javascript.
The source to the whole thing is GPL’d so there is some hope that this will allow BBS’s to continue out there for some time.
Oh yeah and I did get a VPS so I do plan on hosting some of the old files from vaxenrule.com .. In ther interim though you can connect to the ‘underground’ BBS @ 75.127.119.16 … You could telnet in with any old telnet client, but I’d suggest Syncterm!
—-
Update that address has long since passed it is now bbs.superglobalmegacorp.com …!